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Symptoms:

Creating service request fails and you can find "Could not create request on behalf on behalf of the sender." in the Incoming Log, that means the request could not pbe created in the name of the reporter.

Possible Cause:

The email you are sending mail from once had a customer account on JSD and was deleted but still has requests reported by him. Jira didn't remove the user fully, that's why cannot create a new one, but also cannot reactivate the old one.

Diagnosis:

Check if there is a request with the sender's email as the reporter and there is no customer with this email on Administration>User management>Jira Service Desk>Portal only customers.

Solution:

Follow these steps to fully remove the user from JIRA:

  1. remove the sender from the requests where he is the reporter
  2. delete the user using REST: DELETE /rest/api/2/user?username=<sender e-mail> (you must be a site administrator. For more details, see: https://developer.atlassian.com/cloud/jira/platform/rest/#api-api-2-user-delete)
  3. requeue the mail for reprocessing

Remember: You should not delete a user especially once they have interacted with the system. Making them inactive is the preferred solution

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