Always same template is send using JQL filter in notification event

Description

Hello,

I am encountering some issues with the following configuration:

I created a custom field (simple text) that is present on my "create screen" in order to identify the language code (for example: FR or EN).
The purpose will be to send the appropriated template according to the value from this custom field.

Thus I created 2 templates based on the "Create Event" with a different body one in FR the other in EN.
Then I created 2 Notification Events for both templates. Both events are using an JQL filter in order to limit issues matching the value from the custom field called "langdetect": [project = DESK AND status = "To Do" AND langdetect ~ en]
Last but not least I created two contexts in order to associate the templates and events to the project, that uses the Create templates and the correct notifications.

Finally I ve created an JETI workflow post function at the Create Event calling the template from the context.

The problem is that even thought the notification events are filtering the issues in order to call the appropriate template, it is always the first template that is send.
I tried to set the orders in notification and context, but still the first template is always send.

Question1: is it important to set the order when using JQL filters?
Question2: what would be the best Template method for setting up the notification events in my case : using the context or pointing directly on the template?
Note that I tried both, but still only one of the two templates is send.

Thanks in advance

Environment

local installation using wamp for testing

Preliminary Test Cases

None

Assignee

Tibor Hegyi

Reporter

Ricardo Solar

Labels

None

Access to limited visibility issues

None

Product platform

None

Module Dependency

None

Ready for Development

None

Components

Affects versions

Priority

Blocker
Configure